The MU forums have moved to WordPress.org

redirect loop (54 posts)

  1. dainismichel
    Member
    Posted 9 years ago #

    Thanks for your reply, I'd read the eBook. I'm selecting options that are there, and I understand what the options mean, it's just that I don't know the "trick" to get community.domainname.org/userblog/ to work.

    This isn't going to work because of the DNS wildcard: userblog.community.domainname.org

    Is it true that the only way to get MP MU to work out the box is to install into the root directory of a domain and to select subdomains?

    I read on your forum that you are providing limited support for BuddyPress. That's really all I'm interested in actually. Would it make sense for me to join?

    Best,
    Dainis

  2. andrea_r
    Moderator
    Posted 9 years ago #

    If you want the blogs to be in a subfolder, then you don't even need wildcards.

    "Is it true that the only way to get MP MU to work out the box is to install into the root directory of a domain and to select subdomains?"

    No, that's not true. I recently set it up on a site like blogs.domain.com/username/ Works fine.

    Since this is more an installation issue and less to do with BuddyPress, by all means we can help you.

  3. ben_allison
    Member
    Posted 9 years ago #

    Grr. Two different servers, with totally different configurations and on both, installing with sub-folders causes a redirect loop after logging in and trying to go to anything in wp-admin.

    This didn't happen with WPMU2.7 beta...

  4. andrea_r
    Moderator
    Posted 9 years ago #

    ... and I can't reproduce it...

  5. DeFries
    Member
    Posted 9 years ago #

    I'm having the same issue with WPMU 2.7 and have tried just about anything.. but alas

    If this is a server issue - I'm on a plesk VPS what can be done to fix this?

  6. DeFries
    Member
    Posted 9 years ago #

    I noticed it is also browser related.. When I use a different browser I can log in, but as soon as I try and do that again, I can't log in anymore.. and I'm running out of browser to log in :s ..

    found a loop hole.. login to one browser, change password, and then login again with another browser..

  7. andrea_r
    Moderator
    Posted 9 years ago #

    Is it a new install and can you give me a link? :)

  8. illutic
    Member
    Posted 9 years ago #

    I've had that problem too (plesk9 VPS). I first had it installed as subdirs, but after a few days(!) the loop suddenly began to appear.. Re-installing MU didn't help, not with subdirs.
    When I re-installed MU using subdomains it suddenly worked again.

    Btw, could be that for some reason one of the tables in your db needs fixing (had that with a single user account recently).

  9. andrea_r
    Moderator
    Posted 9 years ago #

    Check the config file for the vhost=yes line. Should be yes or no. If it's not either, there's your problem.

  10. DeFries
    Member
    Posted 9 years ago #

    http://frisii.nl is the link to look at.. I have been able to work on it all afternoon, but then again.. I did not log out...

    It was a 2.6.x version and I upgraded it to 2.7 this morning. That's when it all went wrong. I deleted the install, database and everything in between.

    Is the vhost=yes line meant for me or Illutic?

  11. millerdigital
    Member
    Posted 9 years ago #

    I first got a DB connect error, figured out I had entered the wrong user name, fixed that then started getting the Loop error, after reading this thread decided to rerun setup, all I did was backup the wp-config and reloaded the wp-config-sample.php, (no need to re-upload the whole package) and reran the setup, made sure that sub-domain option was checked, made double sure all my settings were correct, submitted, then got the rest of the setup. My lesson was be sure to get all the settings right the first time or need to reload the setup.. fyi

  12. illutic
    Member
    Posted 9 years ago #

    I guess it's for you, been a while since I had this problem (and already had some support from ron_r on their support forum).

  13. andrea_r
    Moderator
    Posted 9 years ago #

    yep, it was for miller. :)

  14. tdjcbe
    Member
    Posted 9 years ago #

    What's with all of the redirect loop errors all of the sudden? Something isn't right.

  15. ayvegh
    Member
    Posted 9 years ago #

    I setup a new 2.7 fresh install with subdomains.

    Everything was working fine until I added a second blog.

    Now, the second blog user can log in, but I can't log in as the admin account (I get the loop error).

    Anyone have any ideas? I've tried deleting my cookies, and I still have the same issue.

    EDIT: I seem to have fixed the issue.

    I had manually changed the admin username to something else in the database, and had forgotten to change the site_admins array value in the wp_sitemeta table to the new username. If you are having trouble, and you manually changed the username of the admin account, I suggest looking into this as a possible fix.

  16. ColaTM
    Member
    Posted 9 years ago #

    Sure seems like a "Bug" to me. I just removed the added user from the DB and it works fine now. Switched over to subdirs and all is good.

  17. andrea_r
    Moderator
    Posted 9 years ago #

    Uh, no. If you switched to subdirs becasue the subdomain logins weren't working, then you didn't set the server up right. Hardly a bug.

  18. fdqepd
    Member
    Posted 9 years ago #

    had same issue, fixed by reseting db user permissions to all privileges.

  19. magi182
    Member
    Posted 9 years ago #

    I got the infinite redirect on a specific wp-user account. Fixed it by deleting and recreating the wp-user. The other user accounts were still working normally. FWIW, the particular user account was created by me using "create user" on the backend, while logged in as the site admin, rather than by the user signing up for an account.

  20. lhovo
    Member
    Posted 9 years ago #

    I was wanting to test this in a subdirectory,
    ie mydomain.com/blogs
    I selected subdirectory assuming setup will setup blogs like
    mydomain.com/blogs/myblog

    This caused the redirection loop for me when trying to login, the url points to
    mydomain.com/blogs/wp-login.php?redirect_to=http%3A%2F%2Fmydomain.com%2Fblogs%2Fwp-admin%2F

    From what I can understand is trying to redirect to mydomain.com/blogs/wp-admin/ so I manually typed it in and still has the redirection loop.

    Reinstall to subdomain, works fine.
    I have a wp install running fine with redirections on the mydomain.com so this would lead me to believe that this is not the problem here.

    So the question is does mu support such a request?
    If not maybe this is where everyone is getting stuck?

    Cheers
    Lhovo

  21. Brayne
    Member
    Posted 9 years ago #

    I too had been experiencing the dreaded loop. Weird too, sub-domains no problem, sub-directories and wp-admin would loop into the night. I saw the post about browsers and experimented. FF is holding a big grudge.... I emptied the cache and re-launched FF and it works.... it works in IE7 and in Safari... So this turns out to be a browser issue for me... Hope this helps others.

  22. lhovo
    Member
    Posted 9 years ago #

    I have fix my looping as well.
    As part of the installation process I modified "wp-blog-header.php"
    changing

    if ( !file_exists( dirname(__FILE__) . '/wp-config.php') && !file_exists( dirname( dirname(__FILE__) ) . '/wp-config.php'))

    to

    if ( !file_exists( dirname(__FILE__) . '/wp-config.php') /*&& !file_exists( dirname( dirname(__FILE__) ) . '/wp-config.php')*/)

    This enabled me to install wpmu with a existing installation below it.

    Forgetting to change it back seemed to cause the loop, that all said I am now getting corrupt database errors when adding blogs.
    Something I will be looking into further in the next few days..

  23. eyecool
    Member
    Posted 9 years ago #

    I was having the redirect loop error after initial install. It was very frustrating because I done everything by the book, double, tripled and quadrupled checked everything. What baffled me was that I already have a successfully installed mu installation on my server.

    HERE IS HOW I FIXED MYDOMAIN.COM

    1. I deleted the wp-config.php
    2. I re-uploaded wp-config.php
    3. I used my gmail account as the email for the admin registration

    VOILA!

    I had been using myname@mydomain.com for the initial setup page registration. Problem was, I hadn't created the user or email account for myname@mydomain.com. I used my gmail account (an off my server account) and it worked.

    As soon as I logged in to the admin account, I used the MU control panel to change my email address to myname@mydomain.com. =)

    HOPE THIS HELPS SOMEONE!

  24. derosion
    Member
    Posted 9 years ago #

    Hi,

    I don't know if this is relevant to anyone here but I found the problem in my case was that with my server providor (dreamhost) I had it set up in the panel as follows:

    "Add "www." if somebody goes to http://domain.com/"

    so I changed it to:

    "Remove "www." if somebody goes to http://www.domain.com/"

    and that seemed to do the trick.

    With this in mind I have to agree with those who are saying it is not a bug. It's simply the way you have your domain/hosting set up to handle the 'www'.

About this Topic

  • Started 10 years ago by corbosman
  • Latest reply from derosion