The MU forums have moved to WordPress.org

Inserting an image from the web in 2.6 (19 posts)

  1. tarmentano
    Member
    Posted 14 years ago #

    How does one insert an image from another website in a blog post. When I use the add media feature and select the image url, it simply adds the link (a href=) instead of embedding it as I would prefer(img src=). Is there something I am missing? Check out the video I made to show you exactly what I am talking about - http://screencast.com/t/hHcalBLzV4f

  2. andrea_r
    Moderator
    Posted 14 years ago #

    I know exactly what you mean. :) I noticed this yesterday and I've been trying to track down if it's expected behavior or not.

    There's absolutely nothing in the codex about it, as that area is still showing info for the old admin design.

  3. boonika
    Member
    Posted 14 years ago #

    I think that Custom Fields could solve your problem. I didn't try to link images outside my server but it won't hurt if you try.

    Also this is an old tutorial on one of my websites but I don't think it will work for you cause you already tried 'old school' embedding:
    http://moleskineproject.com/instructions/

  4. andrea_r
    Moderator
    Posted 14 years ago #

    boonika, I don't see how custom fields would solve the issue. I;d have to tell users to do something harder and ignore half of what is right in front of them and a bit more intuitive.

    When adding an image, right under the "upload an image from your computer" area is a second option - get an image from an existing URL. That's the one we're talking about.

    Now that I think about it, I'm gonna go read trac and see if anything got removed.

  5. boonika
    Member
    Posted 14 years ago #

    Andrea, I'm not saying that it will solve this issue. I just suggested to give it a try. On my homepage I use custom fields to display post thumbs (no text) which links to the rest of the article. I use a code bellow and I paste thumb's URI as value (for 'Image' key). But I didn't try to link images placed on other sites. Sorry.

    $values = get_post_custom_values("Image");

    Also check (embeding HTML into posts using Custom Fields):
    http://www.matteoionescu.com/wordpress/embed-html/

    I know this doesn't solve the problem but maybe someone finds it useful.

    Cheers

  6. boonika
    Member
    Posted 14 years ago #

    Just tried it - inserting images (thumbs) from another web site by using custom fields work. Of course You'll have to use a plugin for that. Just paste the image address inside Value field. It is called Get The Image Plugin. I hope you find it useful.

    http://justintadlock.com/archives/2008/05/27/get-the-image-wordpress-plugin

  7. Ovidiu
    Member
    Posted 14 years ago #

    I had the same surpise a couple of days ago and just switched to using tinymce editor 3.1 http://wordpress.org/extend/plugins/tinymce-advanced/

    this gives you back the button to insert images ;-) but I have to use it in conjunction with plugin commander...

    btw. that makes me think how do my users insert their images? I haven't heard anyone complaining lately....

  8. VentureMaker
    Member
    Posted 14 years ago #

    Ovidiu, my users are uploading images and have no issues.

    Allowing people to insert images and other stuff from other websites is kinda security risk, don't you think? :) XSS vulnerability, if I'm not mistaken.

  9. Ovidiu
    Member
    Posted 14 years ago #

    I am only talking about inserting images. The button: 'Insert IMage' from the tinymce editor went missing.

  10. andrea_r
    Moderator
    Posted 14 years ago #

    When adding an image, right under the "upload an image from your computer" area is a second option - get an image from an existing URL. That's the one we were *originally* talking about.

  11. Ovidiu
    Member
    Posted 14 years ago #

    @andrea

    *blush* I haven't seen that option. I was used to that insert/edit image button, I didn't know they had jsut moved that function over there :-(

    Actually that is exactly what I was looking for. Sorry for confusing this thread.

  12. VentureMaker
    Member
    Posted 14 years ago #

    LOL :) Who confused who? :)))
    Probably it's because it's hot, damned hot. At least here, where I am ;)

  13. webmaestro
    Member
    Posted 14 years ago #

    Any update on this? I've got users wondering how to add pictures from a URL, as opposed to uploading them. The primary benefit here, is that they don't use up any of their precious quota.

    From URL
      =================
      Image URL:
      Image Description:

    I guess I could go the Advanced TinyMCE plugin route (thanks for the idea, Ovidiu!), but I'd rather not give my users that much control. I'm having a hard enough time convincing them that not everything needs to be BOLD and all caps.

  14. lunabyte
    Member
    Posted 14 years ago #

    "The primary benefit here, is that they don't use up any of their precious quota."

    But eats up someone else's bandwidth bill, which is rude.

  15. andrea_r
    Moderator
    Posted 14 years ago #

    I'm wondering why it's there, actually.

    If it's one of your *own* images... well, you shoudl be able to access that another way.

  16. webmaestro
    Member
    Posted 14 years ago #

    Heh... assumptions, assumptions...

    Fortunately, my users tend on the 'safe' side of that whole copyright thing, and link to photos and graphics uploaded to their blogs' "parent" site, or to photos they post to their online web space.

    Now I've got users complaining that they can't insert photos & graphics via URL.

    Any chance we can get that functionality back?

  17. lunabyte
    Member
    Posted 14 years ago #

  18. webmaestro
    Member
    Posted 14 years ago #

  19. webmaestro
    Member
    Posted 13 years ago #

    Update: This issue was resolved for WPMU (there's now a setting in WP-Admin > Site Admin > Options):

    http://trac.mu.wordpress.org/ticket/738

About this Topic

  • Started 14 years ago by tarmentano
  • Latest reply from webmaestro