The MU forums have moved to WordPress.org

Index.php/Posts - permalinks redirect to page.php (3 posts)

  1. dkiesow
    Member
    Posted 15 years ago #

    Running a WPMU install with about 20 blogs. Have had this trouble on several blogs - currently seeing it on two specifically. The same problem occurs regardless of what theme/template is being used.

    Permalinks from the index.php page are redirecting posts to the page.php template instead of single.php. This was not happening originally - so I must have changed something by accident - but no idea what.

    Here is an example: http://blogs.nashuatelegraph.com/livefreeordine/2008/08/20/aspirations-bistro-gets-a-facelift/

    (the new DNS is still rolling out so you may get an entirely wrong page)

  2. dkiesow
    Member
    Posted 15 years ago #

    FYI - I looked through the DB, checked settings everywhere and gave up. Exporting the full blog, creating a new blog and reimporting the content solves the problem - whatever it is.

  3. schmoove
    Member
    Posted 15 years ago #

    Solved!

    It seems to be an issue with permalink settings for a blog being corrupted. To fix, login to a blog's Backend via Site Admin, click Settings then Permalinks, and change the settings back to the default (?p=20 etc). Click Save and then change it back to whatever it was before. This will recreated whatever permalink data had been corrupted.

    So hopefully that works for everyone

About this Topic

  • Started 15 years ago by dkiesow
  • Latest reply from schmoove