The MU forums have moved to WordPress.org

how to change Max upload file size for site_admin only (8 posts)

  1. Ovidiu
    Member
    Posted 13 years ago #

    I was just wondering how to change 'Max upload file size' for the main blog only.

    I tried going site admin => blogs, click on edit on the main blog, but I only find the field to change the 'Blog Upload Space Quota' which btw. does not get saved even if I change it and click update settings.

    Running wpmu 2.6.1 anyone able to duplicate this or are you all fine?

  2. Ovidiu
    Member
    Posted 13 years ago #

    anyone? I want to give my main blog the option to upload bigger files and have more space :-)

  3. VentureMaker
    Member
    Posted 13 years ago #

    I really doubt you can do that.
    'Max upload file size' is PHP option, not WPMU. You can set custom PHP options for a separate website on the server.
    That's why I think this is impossible.

  4. andrea_r
    Moderator
    Posted 13 years ago #

    Not impossible as long as those limits are within the php.ini values.

    At the very least, under 'edit blog' it *should* be saving that value.

    If you'll be doing it just the once for Site Admin, I'd be inclined to just do it in the database.

  5. Ovidiu
    Member
    Posted 13 years ago #

    @andrea:

    Assuming all sizes are within my specs inside php.ini =>
    I have i.e. 25MB space usage / blog and 2048kb max file size set up as a general rule, but want to upload 6 video files each 5MB for the main blog.

    I thought I could just this on a per blog basis going to site-admin => blogs => then edit the main blog, but the values are not getting saved. I tried modifying the 25MB option inside the DB but somehow it gets overwritten as soon as I change it and the 2048kb I can't even find inside the wp_1_options table :-(

  6. Ovidiu
    Member
    Posted 13 years ago #

    ok, found out why I couldn't change my max. upload space:

    I was using the premium plugin from premium.wpmudev.org I just had to subscribe myself to a bigger package :-)

  7. binh
    Member
    Posted 13 years ago #

    I'm glad you found the solution :)

  8. Ovidiu
    Member
    Posted 13 years ago #

    well, thats only half a solution, I solved the problem of giving more upload space to the main blog, but I still need to figure out how to allow the main blog (aka me) to upload bigger files than the rest of the crowd :-)

About this Topic