The MU forums have moved to WordPress.org

Image uploading problems! (27 posts)

  1. Yoshi_S
    Member
    Posted 16 years ago #

    Hello guys,
    I have set up Wordpress MU on my EU-Domain.
    There was an error with the import-function but I fixed it with the help of this Forum. Now a second error is making me to ask here for a solution. I searched the Forum for a fix but I found nothing. When I try to upload an image, this error appears: "Unable to create directory /var/www/vhosts/bloggg.eu/httpdocs/wp-inst/wp-content/blogs.dir/1/files. Is its parent directory writable by the server?"
    The CHMOD of "blogs.dir" is 777, the group www and the owner wwwrun but the directorys for the files cannot be created.
    I hope you guys can help me :)

  2. Yoshi_S
    Member
    Posted 16 years ago #

    Can nobody help me fixing this problem ?!
    It's very important.

  3. dbasulto
    Member
    Posted 16 years ago #

    has anyone come to a solution on this???
    it's happening on latest build...

  4. Yoshi_S
    Member
    Posted 16 years ago #

    We need help, please :(

  5. Yoshi_S
    Member
    Posted 16 years ago #

    Please guys help me, has nobody a solution for this problem?!

  6. andrea_r
    Moderator
    Posted 16 years ago #

    I don't know how to fix it, but I *do* know this was an issue with the 2.0 version of the regular WP. At the very least it'll help assure you that you aren't crazy. :)

  7. samchng
    Member
    Posted 16 years ago #

    Chromd your wp-inst and wp-contents 777 too.
    Then perhaps you can try using ITDamager's .htaccess. Hope it helps. I am just stabbing in the dark here, as that is what I will do if I were you currently.

  8. Yoshi_S
    Member
    Posted 16 years ago #

    wp-inst and wp-content are already 777 chmoded, but the problem does not disappear.
    I don't think that the problem is on side of the .htaccess file.

  9. Yoshi_S
    Member
    Posted 16 years ago #

    We hope for an answer.

  10. swayze
    Member
    Posted 16 years ago #

    any resolution as yet Yoshi? I'm having a similar issue with the same perms issue (?)

  11. stutley
    Member
    Posted 16 years ago #

    Well, installing itdamagers htaccess actually solved the problem for me ;)

    What I *do* know is that my problem wasn't related to file permissions or ownership at all...

  12. Lucifix
    Member
    Posted 16 years ago #

    Hi guys / girls,

    I have the same problem as stutley, but idamanger doesn't solve my problem.

    For my blog I'm using virutal host without subdomain but extra directory.

    When I try to upload image i recived this error:
    Unable to create directory /home/ursuro01/html/subdomain.mysite.com/wp-content/blogs.dir/8/files/. Is its parent directory writable by the server?

    Afcore I check all chmod (set to 777) and looked in wp-content/blogs.dir/ directory. Number 8 is number of registered member who wants to upload photo / that directory is created automaticly. But I couldn't find subdirectory /files.

    If I manualy create it everything works just fine.

    Does anyone have idea why directory /files doesn't create itself?

  13. Sproke
    Member
    Posted 15 years ago #

    Hi, I'm having the same problem. I do not want to be creating the directories by hand, because the site is for my Mum, and she's got a lot of uploading to do.

    Has there been any resolution yet? I've searched and searched but have had no sucess.

  14. korske
    Member
    Posted 15 years ago #

    It looks like you are running your site on an Apache web server with safe_mode on. Turning safe_mode off should fix your problem.

    This is something that needs to be done by your server admin or web host.

    - Korske

  15. josefebus
    Member
    Posted 15 years ago #

    Thank Korske!

    Turning safe mode off solved the problem!

  16. adaptiman
    Member
    Posted 15 years ago #

    I'm having the same problem. Safe mode (in PHP) is off. The permissions and owners are correct. Any other suggestions about what is causing this? I'm using the 2-12 nightly.

  17. drmike
    Member
    Posted 15 years ago #

    The permissions and owners are correct.

    May want to actually post them to be sure instead of assuming that they are. blogs.dir needs to be set to 777. It may be set to 755 instead.

  18. adaptiman
    Member
    Posted 15 years ago #

    I've verified that the permissions of bloqs.dir are 777. That's not the problem.

  19. MIW54
    Member
    Posted 15 years ago #

    I write in this thread as it sounds I have the problem as adaptiman.

    I turned off php safe mode, but it didn't help. Owner of a new directory on the server is always "webserver", if I change owner to "you" images can be uploaded. "Webserver" is by default the owner of blogs.dir directory and all directories below it. How can this be changed?
    Any help appreciated

  20. MIW54
    Member
    Posted 15 years ago #

    Right now it seems that changing php safe mode to off helped after all. It just took a couple of hours before the change took place.

  21. freda
    Member
    Posted 15 years ago #

    sorry, i donn't know.

  22. korske
    Member
    Posted 15 years ago #

    When safe_mode is turned off, the httpd/apache service needs to be restarted.

    For anyone else that runs into this problem, you can confirm the status of safe_mode by creating a php file with the following lines.

    <?
    phpinfo();
    ?>

    View the page in your browser and look for the safe_mode setting.

  23. RDI
    Member
    Posted 14 years ago #

    Thanks - that fixed it for me ...

    the test php info - file - kept me sane ...

  24. adaptiman
    Member
    Posted 14 years ago #

    Followup - it turns out that a version of Podpress 8.5 was causing my error. I upgraded to Podpress 8.8 and the error went away. The Podpress author has confirmed that this was a bug in his plugin and has addressed it.

  25. ajbird
    Member
    Posted 14 years ago #

    woot

    get it working.. but now that permissions are set to 777 and safemode is off... is that not a security problem???

    thanks

  26. Anonymous
    Unregistered
    Posted 14 years ago #

    This worked for me, using a Plesk environment:

    Make sure the web server user (apache in my case) is a member of the group owner of the blogs.dir folder (psacln in my case.) Doing this enabled me to keep the blogs.dir and subfolders 775.

    usermod -G psacln apache

  27. Success
    Member
    Posted 14 years ago #

    Can someone confirm if blogs.dir should be 777 or 755?

About this Topic