The MU forums have moved to WordPress.org

Iktib up and ready (8 posts)

  1. amnesiak
    Member
    Posted 16 years ago #

    Well Iktib is up and almost 100% complete.

    After a few tweaks here and there, I hope that it'll be to everyone's liking!

    http://www.iktib.com

  2. shredder
    Member
    Posted 16 years ago #

    It looks great! Nicely done.

    amnesiak: quite a few people (myself included) are looking to produce a layout showing 'latest blogs', 'recently updated' etc.. Could you share a few pointers? Maybe the construction of your 'home.php' (or your theme?)?

    Thanks,

  3. neurone
    Member
    Posted 16 years ago #

  4. shredder
    Member
    Posted 16 years ago #

    thanks neurone

  5. amnesiak
    Member
    Posted 16 years ago #

    thanks for the kind comment.
    I'm sorry for not responding earlier.

    If you have any specific questions I'll be happy to answer them.

    To be more specific about displaying the latest blogs on the main page.

    go to

    http://wpmudevorg.wordpress.com/project/List-All

    you will notice that there is a small tag that you need to place and with one word that needs to be changed in order to display what you want.

  6. NickR
    Member
    Posted 16 years ago #

    I use that plugin on my site as well...its a very nice plugin to have. It's been around for a while, I figured most everyone knew about it by now.

  7. debrouille
    Member
    Posted 16 years ago #

    Hey Andrew,

    thanks for you plugin 'list-all'!

    I had to fix something to get it work with a WPMU-installation without vhost enabled.
    The problem was that the code assumed the use of vhost. So the links to the blogs were in form of blogname.domain.com while a non-vhost installation would have urls in form of domain.com/blogname.

    Basically i just introduced a switch on the 2 code lines where the link is build. There might be a nicer way to do this, but at least it works ;-)

    Simply replace (line 29)
    tmp_domain = $wpdb->get_var("SELECT domain FROM " . $wpdb->blogs . " WHERE blog_id = '" . $bid . "'");
    by

    if( defined( "VHOST" ) && constant( "VHOST" ) == 'yes' )
    $tmp_domain = $wpdb->get_var("SELECT domain FROM " . $wpdb->blogs . " WHERE blog_id = '" . $bid . "'");
    else
    $tmp_domain = get_blog_option( $bid, "siteurl");

    and (line 36)

    echo $begin_wrap . "<a href='httpREMOVE_ME://" . $tmp_domain . $tmp_path . "'>" . $tmp_display . "</a>" . $end_wrap;

    by

    if( defined( "VHOST" ) && constant( "VHOST" ) == 'yes' )
    echo $begin_wrap . "<a href='httpREMOVE_ME://" . $tmp_domain . $tmp_path . "'>" . $tmp_display . "</a>" . $end_wrap;
    else
    echo $begin_wrap . "<a href='" . $tmp_domain . "'>" . $tmp_display . "</a>" . $end_wrap;

    I hope you can use this! Let me know ;-)

    PS: any clue how to put code with the http:slash-slash in this forum?

  8. andrewbillits
    Member
    Posted 16 years ago #

    debrouille,

    I just sent you an email :)

About this Topic

  • Started 16 years ago by amnesiak
  • Latest reply from andrewbillits