The MU forums have moved to

Help me sign-up user in my blog. (5 posts)

  1. realsol
    Posted 15 years ago #

    I guess I should have did more research before writing my log-in form. I am creating a widget for my blogs that will not just let a user sign in but also creates a form to let them sign up for the blog. I don't want to send someone back to the main blog. I just want to add the user to the current blog. I am requiring additional info so I trust who makes it this far.

    All of my blogs are actually separate 'sites' that I want to keep separate. I thought I was going down the right path with wpmu_validate_user_signup ($user_name, $user_email) and wpmu_create_user ( $user_name, $password, $email) and add_user_to_blog ( $blog_id, $user_id, $role ) but starting with the validation I am getting this in my php code:

    Fatal error: Call to undefined function username_exists() in /home/content/r/e/a/realsol/html/wp-includes/wpmu-functions.php on line 886

    I just want a simple sign-up procedure. I am surprised there isn't already a plug-in that allows this.

    Please help. 200 lines of code and no where to go.


  2. andrea_r
    Posted 15 years ago #

  3. MazZziKa
    Posted 15 years ago #
    this not contain quick registeration
    i hope u make it integrated with WP Hashcash

  4. realsol
    Posted 15 years ago #

    I completed the registration portion and am adding the user just fine, but when I try to log-in the user, it doesn't seem to work.

    I'm using:

    $result = wp_login($_REQUEST["user_name"],$_REQUEST["password"]);

    $result = '1' but I am not getting the user logged in. What am I doing wrong?


  5. Heaven Interactive
    Posted 14 years ago #

    This was a problem in WPMU 2.7. The function wpmu_create_user() appears to be depended on functions from the file 'registration.php which is located in wp-includes/registration.php

    Although everything else in my WPMU install works great, when I tried to use wpmu_create_user() without including this file, it did not work because of the dependencies.

    Including that file gets the proper functions in there. I don't know if I edited something that took this file out of the path, but it works now.

About this Topic

  • Started 15 years ago by realsol
  • Latest reply from Heaven Interactive