The MU forums have moved to WordPress.org

Main WPMU site active Subdomains and Wildcard still broken (17 posts)

  1. karjames
    Member
    Posted 9 years ago #

    My main site

    http://paradiseparkmasonicclub.com/index.php is up and working, every time I try to create a new blog

    i.e.
    manager.paradiseparkmasonicclub.com
    president.paradiseparkmasonicclub.com

    It takes me to a plesk page. Which is the "new page" for my server company Edatarack.

    I have talked to Edatarack the server company and they assure me that wildcards have been enabled.

    What am I doing wrong?

  2. karjames
    Member
    Posted 9 years ago #

    OK sorry one more thing. So Wildcards are not broken because anything.paradiseparkmasonicclub.com work and gives me a plesk page. So the better question is, why don't I see wordpress on my newly installed blogs?

  3. Ovidiu
    Member
    Posted 9 years ago #

    well, how does your .htaccess look like? It seems the wildcard domains are pointing to the right place but wpmu is not picking the subdomains up...

  4. MrBrian
    Member
    Posted 9 years ago #

    Wildcards are enabled DNS-wise, but you need also a ServerAlias in your apache config. Something your host needs to do also. This is one of the reasons it's highly recommend you have a VPS or dedicated, as you have access to do this stuff on your own.

  5. andrea_r
    Moderator
    Posted 9 years ago #

    If the wildcards were working correctly, then anything.paradiseparkmasonicclub.com should show the main site. If it shows anything else, it's not done right.

    you need wildcards in Apache.
    You need a wildcard domain record.

    If all else fails, send your host the readme.txt file from the download.

  6. albaity
    Member
    Posted 9 years ago #

    can you tell me about wildcard domain record , is it from the domain control panel or is it from whm or cpanel

  7. karjames
    Member
    Posted 9 years ago #

    Here is my response from Edata rack when I sent them the readme.txt and told them my .htaccess was not editable.

    Please advise

    Dear Karla

    The only PHP function that we can control on a site by site basis is the php safe mode. That has been turned off for your domain. If you wish it turned on for your script to work, we can do that. The php.ini file can not be changed as it is a root file and that means it controls all domains on your server. All php.ini functions are set for the shared server and its setup to function with Plesk by Plesk. Any changes to that file effect all accounts on the server and the working of Plesk on the server. All files for your site need to be in the httpdocs folder and the cgi-bin for cgi scripts. There are no restrictions in those folders.

    With regards to php.ini - this is a server-wide setting, which is not changed on a hosting environment. We can remove PHP safe mode from hosting accounts on an individual basis.

    You need to upload the file named php.ini/.htaccess to the directory where you were trying to upload your site. If there is no .htaccess file yet, you can create one (it's just a text file with the name '.htaccess'). .htaccess files (or "distributed configuration files") provide a way to make configuration changes on a per-directory basis. A file, containing one or more configuration directives, is placed in a particular document directory, and the directives apply to that directory, and all subdirectories thereof.

    Most common reason of the issue is that the php.ini configuration has expired, you may need to enable it back again by enabling it back again from the .htaccess file or there is a new server configuration that did not match from the php.ini file configuration, you need to reupload/re-install the file.

  8. andrea_r
    Moderator
    Posted 9 years ago #

    "and told them my .htaccess was not editable."

    So... is it not getting created on install?

  9. karjames
    Member
    Posted 9 years ago #

    Andrea it's getting posted. It's there but it is not editable. When i click on it to view in file manager here is the error message

    Error: Unable to show file /httpdocs/.htaccess: Unable to read the file or the file format is not supported.

    Here is the response from Edatarack

    I suggest you to reupload it Im sure you have a back of it. Your ftp client may very well allow you to change file permissions from the client window by a "right click", and then a numeric value selection for file permissions. If not, you will have to do a litle research on changing file permissions or "chmod" of file permissions.

  10. MrBrian
    Member
    Posted 9 years ago #

    chmod .htaccess to make it writable. You can do this with your FTP client by usually right clicking the file. Chmod value of 666 will work. Avoid using those stupid control panel managers anyway, just use FTP. Also, your host sounds like a bunch of nobs (no offense). Most hosts will do something that simple for you.

  11. karjames
    Member
    Posted 9 years ago #

    I tried to do a 777 in FTP I also tried to edit it in FTP, it says and I quote Check the Fetch transcript window for more information Server Responded ".htaccess: Operation not permitted"

  12. karjames
    Member
    Posted 9 years ago #

    I also tried a 666 chmod and I still am not able to change the permissions.

  13. andrea_r
    Moderator
    Posted 9 years ago #

    Then it needs to be CHOWNed to the web account user.

  14. onlinebisnes
    Member
    Posted 9 years ago #

    try rename it to something else.
    eg. htaccess1.txt

    then download to your pc.

    edit the files via text editor.

    upload to your server again.

    then rename back to .htaccess

    I done this step when I have the same prob.

  15. karjames
    Member
    Posted 9 years ago #

    It will not allow me to download to my computer. Permission denied. I have tried to 777 and 666 my file either in .htaccess1 or .htaccess it refuses due to permission as well.

  16. andrea_r
    Moderator
    Posted 9 years ago #

    Then it needs to be CHOWNed to the web account user.

  17. Turker
    Member
    Posted 8 years ago #

    what to change on .htacess?

About this Topic