The MU forums have moved to WordPress.org

1 ... 6 7 8

Sitewide Feed (213 posts)

  1. binh
    Member
    Posted 13 years ago #

    itdamager, look like your domain is bought and parked by someone else and it's no longer your website.

    Sadly true.

  2. Ovidiu
    Member
    Posted 13 years ago #

    I noticed that too :-( but it seems itdamager is long gone...

    btw. it seems the eaccelerator object cache plugin is no longer working with wpmu 2.6 or the sitewide feed doesn't notice that I am using that plugin :-(

    any feedback on this issue?

  3. jeremybyrne
    Member
    Posted 12 years ago #

    I wasn't able to find a solution to using v0.3.2 of wpmufeed with subdirectory installs of WPMU, so I've made my own. Instructions are:

    • Edit wpmufeed.php
    • Replace line 80 with the following:
      if (preg_match('/^\/[a-zA-Z0-9_\/\-]+\/$/',$_POST['triggerurl']) || constant( 'VHOST' ) != 'yes') $triggerurl = $_POST['triggerurl'];
    • Replace line 83 with the following:
      if (preg_match('/^[a-zA-Z0-9_\-]+\/$/',$_POST['commentsurl']) || constant( 'VHOST' ) != 'yes') $commentsurl = $_POST['commentsurl'];
    • Replace line 86 with the following:
      if (preg_match('/^[a-zA-Z0-9_\-]+\/$/',$_POST['pagesurl']) || constant( 'VHOST' ) != 'yes') $pagesurl = $_POST['pagesurl'];
    • Configure "Sitewide Feed Options" (ie. "Site Admin|Site Feed") as follows:
      • Trigger Blog ID: 1 (default)
      • Feed URL (relative path): ?wpmu-feed=posts (default)
      • Comments Feed URL (appended to Feed URL): &wpmu-feed=comments
      • Pages Feed URL (appended to Feed URL): &wpmu-feed=pages
      • Other settings, to taste.

    Note: this method bypasses the regex sanity check on the feed URLs, but that should be fine as long as you use the settings provided above.

1 ... 6 7 8

About this Topic

  • Started 15 years ago by itdamager
  • Latest reply from jeremybyrne