The MU forums have moved to WordPress.org

Crazy subblogs redirects - PLEASE HELP (11 posts)

  1. boonika
    Member
    Posted 12 years ago #

    Situation:

    I have two domains (DOMAIN-1 and DOMAIN-2) pointing to my dedicated virtual server. Both have their own (different) database and user. DOMAIN-1 works just fine. DOMAIN-2 has gone mad. When I try to visit sub-blogs (blog1.DOMAIN-2) I get redirected to DOMAIN-1 homepage. How is that possible?

    Btw, DOMAIN-2 has imported database backup cause I've moved from (gs) to (dv). I'm using Plesk.

  2. andrea_r
    Moderator
    Posted 12 years ago #

    Have you contacted support? This sounds like a config issue. Hard to say exactly without being in there and looking at it, really.

  3. boonika
    Member
    Posted 12 years ago #

    Yes, I've contacted them but they think it could be WP problem. They really want to help. They even gave me this link cause they think it can help me:

    http://codex.wordpress.org/Changing_The_Site_URL

    But I don't think this has got anything to do with it cause I didn't change domain name. I've just moved to another server.

    EDIT: Also, at my Plesk, there is something called 'DNS recursion settings'. YOu can choose from three options:

    - Any host
    - Localnets
    - Localhost

    Mine is set to 'Localnets' by default. I've tried to save it with 'Localhost' but nothing changed so I moved back to 'Localnets'.

  4. boonika
    Member
    Posted 12 years ago #

    Anyone knows where 'siteurl' and 'home' are stored inside DB?

    Thanks

  5. boonika
    Member
    Posted 12 years ago #

    Found it... that's not it. Huhhhhh... I think I'll have to send a little 'explanation' to blog owners. I just hate times like this:)

  6. boonika
    Member
    Posted 12 years ago #

    OK, I'm a bit frustrated right now. I've droped all DOMAIN-2 'db' tables, and I've also deleted 'wp-config.php'. Then I configured MU (db_name, db_user...) again, prayed for about a minute, created a test blog, tried to visit it and... got redirected to DOMAIN-2... AGAIN!

    When I come home, I'll delete that 'db' and create another one. Then I'll do a fresh MU install. If that won't work, I'll apply for army.

  7. boonika
    Member
    Posted 12 years ago #

    This sounds promising: http://vernonkesner.com/230/wordpress-mu-subdomains-on-plesk.php

    I'll let you know what happens.

    PS: I'm posting all these comments in case someone else will face this problem in future

  8. boonika
    Member
    Posted 12 years ago #

    Still no good news for me (from me) but I want to share what has happened lately.

    I've deleted entire DOMAIN-1 and DOMAIN-2 databases. I've removed those domains from user account. Then I've added those domains again, added new databases and users for each and then did a fresh WordPress Multi User install on both domains. But nothing has changed. The old problem (see my 1st post) keeps on coming back.

    This could be 'the wildcard problem' but what confuses me the most is how come DOMAIN-1 works fine while DOMAIN-2 is total wacko? Anyway, I'll try with wildcards and wait to see what happens. Cheers.

  9. boonika
    Member
    Posted 12 years ago #

    Problem is finally solved. So this is a short info for all of you who'll be facing this in future. Here's what we did:

    1. First we added a new 'A' DNS record: *.domain.com (replace domain.com with your own domain name and also don't forget to add * before .domain.com)

    2. Than we added ServerAlias *.domain.com inside /var/www/vhosts/domain.com/conf/httpd.include - create it if it doesn't exist. Also, you have to have root access. Don't forget to replace domain.com with your own domain name.

    3. SKIPPED!!!

    4. Restart Apache: service httpd restart

    ----------------------------------------

    Why step 3 was skipped? Problem detected! When we tried to add /usr/local/psa/admin/sbin/websrvmng –reconfigure-vhost –vhost-name=domain.com all settings inside /var/www/vhosts/domain.com/conf/httpd.include were set back to default. Why? We do not know.

    ----------------------------------------

    NOTICES:
    - Server we use is (mt)'s Dedicated Virtual with Plesk control panel

    - We were using Putty for root access

    - This article helped us a lot:
    http://vernonkesner.com/230/wordpress-mu-subdomains-on-plesk.php#comment-26949

    - More (possibly helpful) articles:
    http://quick-and-dirty-code.com/archives/21/use-wildcard-dns-in-3-steps/
    http://mu.wordpress.org/forums/topic.php?id=925
    http://www.blogopreneur.com/2006/11/06/installing-wordpress-mu-on-a-cpanelwhm-server/
    http://www.affiliates4u.com/forums/widgets-coding-ajax-php-technology-affiliate-marketing/70714-help-installing-wordpress-mu-subdomains-using-plesk.html
    http://kb.parallels.com/article_20_955_en.html
    http://mu.wordpress.org/forums/topic.php?id=539&replies=4#post-2848

  10. andrea_r
    Moderator
    Posted 12 years ago #

    Nice & through notes here. It probably will help someone. :)

  11. zarej
    Member
    Posted 11 years ago #

    Thanks boonika your tutorial really helps me to set up wpmu with subdomains. But I have one problem, the old subdomains on my site (before installing wpmu) won't work. Is there any solution for that problem?

About this Topic