The MU forums have moved to WordPress.org

Error establishing a database connection (8 posts)

  1. Andreas84
    Member
    Posted 9 years ago #

    Hi,
    i try to install wordpress mu with the installer,

    wordpressmu/index.php

    db name: a2623306_word
    username: a2623306_spirit
    password: ******
    Database host: mysql3.000webhost.com
    (also tryed with local host)

    if i click on submit i get:
    Error establishing a database connection

    can someone help me?

  2. Andreas84
    Member
    Posted 9 years ago #

    okay i solved this problem by deleting the wp-config.php (i thing it should be automatical deleted or rewritten by a new setup when you entered wrong data and the program cannot connect...)

    or change the error:
    Error establishing a database connection to
    Error establishing a database connection please delete the wp-config.php and begin a new install.

  3. MrBrian
    Member
    Posted 9 years ago #

    You could just edit wp-config.php with the right database information since you put it in wrong. It's common sense.

  4. Andreas84
    Member
    Posted 9 years ago #

    yes i tryed but as i edited and changed the adress where localhost was i got an other error about this is not a supportet url or something like this.

    now i have got it working and an other question:

    i have webspace on a server

    in the readme i understand this not:

    13 Apache
    14 ======
    15 Apache must be configured so that mod_rewrite works. Here are
    16 instructions for Apache 2. Apache 1.3 is very similar.
    17
    18 1. Make sure a line like the following appears in your httpd.conf
    19 LoadModule rewrite_module /usr/lib/apache2/modules/mod_rewrite.so
    20
    21 2. In the <Directory> directive of your virtual host, look for this
    22 line
    23 "AllowOverride None"
    24 and change it to
    25 "AllowOverride FileInfo Options"
    26
    27 3. In the <VirtualHost> section of the config file for your host there
    28 will be a line defining the hostname. You need to add the following
    29 if you want virtual hosts to work properly:
    30 "ServerAlias *.domain.tld"
    31 Replace domain.tld with whatever your one is, and remove the quotes.

    1. how can i access the file httpd.conf if i only have webspace?
    2. <Directory> directive <- where is this folder exactly?
    3. <VirtualHost> section of the config file <- which config file exactly?

  5. andrea_r
    Moderator
    Posted 9 years ago #

    "You could just edit wp-config.php with the right database information since you put it in wrong. "

    Actually that doesn't work because it then does not continue with the install and doesn't create the db tables, so you have to delete it and retry anyway

    @Andreas84 - if you don't understand it, send the directions to your webhost and ask them to enable wildcard subdomains. You only need to do this is you want youruser.yourdomain.com.

  6. ervanerfian
    Member
    Posted 9 years ago #

    Sorry..
    I can't see the real solution for ""Error establishing a database connection"

  7. tanvir
    Member
    Posted 9 years ago #

    some of my client face this issue several times, in most of the cases they put a extra 'blank space' when they copy+past the db name & host name which will causes error. You may check that.

  8. lunabyte
    Member
    Posted 9 years ago #

    "Error establishing a database connection" is simple.

    It means the connection credentials aren't right. Either the username, password, database name, or host is incorrect.

About this Topic

  • Started 9 years ago by Andreas84
  • Latest reply from lunabyte