The MU forums have moved to

.htaccess empty! (12 posts)

  1. epdady007
    Posted 18 years ago #

    the .htaccess file in my public_html folder is empty?
    cant see my wpmu, could this be the problem?

    seems like iv read somthing about this before
    but i cant seem to find it.
    please help!

    File Manager


    Click on a folder icon to navigate.
    Click on a name to view its properties.

    / public_html / (Current Folder)
    Create New Folder
    Upload file(s)
    Up one level
    .fantasticodata 755
    cgi-bin 755
    epps 755
    images 755
    img 755
    plugins 755
    wpmu 777
    Create New File
    .ftpquota 0 k 0600
    .htaccess 0 k 0644
    www 0 k

  2. epdady007
    Posted 18 years ago #

    anyone please?

  3. samchng
    Posted 18 years ago #

    Your .htaccess should not be blank when you have your wp-inst directory in your public_html directory. Also your .htaccess you should try to chromd it to 777. As it always gives me problems with 644. Hope that helps.

  4. epdady007
    Posted 18 years ago #

    HAD IT ON 646

  5. epdady007
    Posted 18 years ago #

    i have also checked with my host about my wildcard dns
    this is what he sent me

    Your DNS Zone contains an A Entry for * in and your ServerAlias/VirtualHost entry in Apache is:

    ServerAlias *
    DocumentRoot /home/fearless/public_html
    BytesLog domlogs/
    <IfModule mod_php4.c>
    php_admin_value open_basedir "/home/fearless/:/usr/lib/php:/usr/local/lib/php:/tmp"
    <IfModule mod_php5.c>
    php_admin_value open_basedir "/home/fearless/:/usr/lib/php:/usr/local/lib/php:/tmp"

    User fearless
    Group fearless
    CustomLog /usr/local/apache/domlogs/ combined
    ScriptAlias /cgi-bin/ /home/fearless/public_html/cgi-bin/

    can someone look at this and tell me if this should work or not ?

  6. andrea_r
    Posted 18 years ago #

    In the first post, you;ve got all your WPMU stuff in its own folder. I know, the instructions said to do that. But put it in the root. :)

    Feel free to email as well: andrea at .

  7. epdady007
    Posted 18 years ago #

    could you explain houw put it in the root

  8. samchng
    Posted 18 years ago #

    Putting it in the root, means having your wp-inst directory in public_html or www directory on your server.

  9. mohamednazmi
    Posted 18 years ago #

    The empty .htaccess is cPanel being sucky.

  10. andrea_r
    Posted 18 years ago #

    Just to update this thread, I helped epdady007 get his site up & running and thought I should mention what we discovered.
    Most of the previous problems were related to the domain setup not recognizing it without the www. Subdomains were not affected (once the host set up the wildcards anyway).
    I fixed it by going into the database and replacing all instances of the main domain to include the www. Not the most elegant fix, but it works.

    If anyone else is having a problem with the empty htaccess in Cpanel:
    - go to your File Manager
    - find in the main MU install directory (probably /public_html/) a file called htacces.dist.
    - click on it.
    - clcik on the right of the page where it says "edit this file".
    - go to the edit window. Scroll down.
    - see the "save file as" box? rename it to .htaccess. Yes, the dot in front, no extension, is important. Click Save.

    Go back to your main domain page and see if that worked or helped any.

    You may have to do the same in the wp-inst directory. (off the top of my head, I didn't check.) And remember to check file permissions. Some hosts have a default of 644 for every file you plunk on the server.

  11. epdady007
    Posted 18 years ago #

    yes and everything working wonderfully!
    thanks to andrea r

    only problemm i had was posting comments
    but that is also working now thanks to this thread!

  12. samchng
    Posted 18 years ago #

    epdady007, glad to see your site up and running. Congrats! :)

About this Topic

  • Started 18 years ago by epdady007
  • Latest reply from samchng