The MU forums have moved to WordPress.org

Strange behavior upgrading 1.3.3 to 1.5.1 (5 posts)

  1. rcwatson
    Member
    Posted 15 years ago #

    I'm on my way to upgrading WPMU 1.3.3 to 1.5.1, then from 1.5.1 to 2.6.2, but have run into some VERY strange issues.

    Here is the process I've followed so far.
    0. Backed up the MySQL database.
    1. Downloaded 1.5.1 from http://trac.mu.wordpress.org/changeset/1497/tags/1.5.1?old_path=%2F&format=zip
    2. Backed up 1.3.3 files to a directory (not TAR) in /usr1/webroot/wordpress_1.3.3_bak_yyyymmdd
    3. Disabled plugins in 1.3.1 via Site Admin
    4. Removed all 1.3.3 files in the /usr1/webroot/wordpress directory.
    5. Unzipped new 1.5.1 files into /usr1/webroot/wordpress directory.
    6. Restored wp-config.php and .htaccess from 1.3.3 backup.
    7. Restored wp-content directory from 1.3.3
    8. Restored the database from the backup

    As expected, when I go to http://sub.domain.com/wp-admin/upgrade.php, I get "This file upgrades you from any previous version of WordPress to the latest. It may take a while though, so be patient.
    Upgrade WordPress ยป". However, when I click the link, I get the following error:

    Warning: Invalid argument supplied for foreach() in /usr1/webroot/wordpress/wp-admin/upgrade-functions.php on line 30

    Line 30 looks to be iterating through a collection of categories:

    foreach ($categories as $category) {

    So, I decided to go to http://sub.domain.com/ to see if the blog is available at all. I get "It doesn't look like you've installed WP yet. Try running install.php.".

    When I click the install.php link, I get "Already Installed You appear to have already installed WordPress. To reinstall please clear your old database tables first.".

    I did some reading in this forum and found posts that said to check the value of wp_users.user_status to see whether it was '0' or '10'. Changing to either value makes no difference.

    If I go back to an empty wpmu database, all is forgiven, but now I have no content. I also don't have the "Site Admin" tab, regardless of what value I put in wp_users.user_status.

    Then I tried restoring the database one table at a time to see which one was messing things up. The table that kills it is the first one I restored, which is wp_users.

    So, now I'm stuck. I can't restore my content and upgrade it. I can't build my content from scratch because I can't enable the Site Admin tab. I'm fairly certain I've done my homework on this and I'm a little miffed that I still couldn't pull it off.

    What did I do wrong?

  2. andrea_r
    Moderator
    Posted 15 years ago #

    Step #8 was unnecessary.

    And when you first went intot he backend, you needed to go to /wp-admin/wpmu-upgrade-site.php to make the needed database changes.
    (Site Admin -> Upgrade)

    The other link you should only use if you're locked out in a login redirect.

  3. rcwatson
    Member
    Posted 15 years ago #

    Andrea_r,

    Thank you. I just tried your suggestion, but when I point to that script, I get:

    Not Found

    The requested URL /wp-admin/wpmu-upgrade-site.php was not found on this server.

    Maybe you meant something else?

  4. andrea_r
    Moderator
    Posted 15 years ago #

    Nope, I snagged the URL from an existing install. Looks like you have missing files.

  5. rcwatson
    Member
    Posted 15 years ago #

    Ah, you are correct. Thank you so much. Very strange how that file (and only that file) got missed in the upload to the server.

    Thanks again.

About this Topic

  • Started 15 years ago by rcwatson
  • Latest reply from rcwatson