The MU forums have moved to WordPress.org

Database Tables Missing. (14 posts)

  1. soladon
    Inactive
    Posted 17 years ago #

    Hello,

    Just reporting my latest error message in case somebody has solved it. (wpmu is the name of the database)

    Fatal Error
    Database Tables Missing.
    The table wpmu::wp_site is missing. Delete the .htaccess file and run the installer again!
    Please check that your database contains the following tables:

    * wp_blogs
    * wp_users
    * wp_usermeta
    * wp_site
    * wp_sitemeta
    * wp_sitecategories

    ----------
    Thanks

  2. soladon
    Inactive
    Posted 17 years ago #

    forgot to say that .htaccess does not exist - was not created and that with this release (28th) tables were not created.

  3. donncha
    Key Master
    Posted 17 years ago #

    I've fixed that bug. It was introduced as part of my attempts to debug the install problems people are having!
    Download the unstable release again. I recreated it a few minutes ago.

  4. donwe123
    Inactive
    Posted 17 years ago #

    Hi,

    I've just intalled the 2005-08-14 version and got the same result.

    Fatal Error
    Database Tables Missing.
    The table wpmu::wp_site is missing. Delete the .htaccess file and run the installer again!
    Please check that your database contains the following tables:
    wp_blogs
    wp_users
    wp_usermeta
    wp_site
    wp_sitemeta
    wp_sitecategories
    If you suspect a problem please report it to support forums!

  5. fry
    Inactive
    Posted 17 years ago #

    Hi,

    I get the same results with 2005-08-15...
    Tables exist - .htaccess is being created; FollowSymLinks is on, mod_rewrite active, ...
    Any hints?

    cu
    Fry

  6. lucid1
    Inactive
    Posted 17 years ago #

    is it installed on the root of the domain? not domain.com/wpmu/files
    but domain.com/files

    thats the way I have to run it anyway...

  7. fry
    Inactive
    Posted 17 years ago #

    It's installed into a subfolder: xyz.domain.com/wpmu/files.
    Does wpmu really require it's own VH?

  8. donwe123
    Inactive
    Posted 17 years ago #

    Hi,

    I've been trying to install WPMU for about a week now and I tried every nightly version since 2005-08-14 with no success. The error I get is:

    Fatal Error
    Database Tables Missing.
    The table wpmu::wp_site is missing. Delete the .htaccess file and run the installer again!
    Please check that your database contains the following tables:
    wp_blogs
    wp_users
    wp_usermeta
    wp_site
    wp_sitemeta
    wp_sitecategories

    I have post this error a week ago and solutions shown by other members does not solve this problem. Does anyone know what I am not doing correctly? I am using Xampp on a Windows XP machine and I tried switching between PHP 4 and PHP 5 but still does not work.

    I am not trying to bump my post. I am just hoping for a solution. Please excuse this post if it is considered bumping.

  9. serenatk
    Member
    Posted 17 years ago #

    I'm getting the same problem, but now instead of being when I tried to install, it's happening when I try to login or register.
    My install version is wpmu-2005-08-26 and when I don't have the .htaccess in the directories I'm getting this:

    Fatal Error
    Database Tables Missing.
    The table wpwl::wpmu_site is missing. Delete the .htaccess file and run the installer again!
    Please check that your database contains the following tables:
    wpmu_blogs
    wpmu_users
    wpmu_usermeta
    wpmu_site
    wpmu_sitemeta
    wpmu_sitecategories

    But, the thing is: the tables were created by the install. I even was able to create the admin login. I can't figure out what is wrong.

    I tried to put the .htaccess and now I'm getting this:

    Warning: main(/my_path/mublogs/wpmu-settings.php): failed to open stream: No such file or directory in /my_path/mublogs/wp-config.php on line 86

    Fatal error: main(): Failed opening required '/my_path/mublogs/wpmu-settings.php' (include_path='.:/usr/local/lib/php') in /my_path/mublogs/wp-config.php on line 86

    Any ideas???

  10. serenatk
    Member
    Posted 17 years ago #

    I changed the settings file name from 'wpmu-settings.php.dist' to 'wpmu-settings.php' and now I have the .htaccess files on the server and I'm not getting the 'failed to open stream: No such file or directory' anymore. But now I keep getting that 'Fatal Error
    Database Tables Missing.'
    I really don't know what to do. What am I missing here??

  11. ajlowe
    Inactive
    Posted 17 years ago #

    I just installe the wpmu-2005-08-27 version and received the following error message:
    """
    Fatal Error
    Could Not Find Blog!
    Searched for example.com/blog/ in database_blog::test_blogs table. Is that right?
    Please check that your database contains the following tables:

    * test_blogs
    * test_users
    * test_usermeta
    * test_site
    * test_sitemeta
    * test_sitecategories

    If you suspect a problem please report it to support forums!
    """
    The fix for me was to use phpMyAdmin to edit the test_blogs table and add a trailing slash to the blog field, so I changed "/blog" to "/blog/".
    I don't know if I will have to do that to every blog or not, but this step got started.
    Cheers,
    Andy

  12. serenatk
    Member
    Posted 17 years ago #

    But Andy, in your case it couldn't find the blog. In all the other ones the problem was "Database Tables Missing" which is different. Add a trailing slash to the blog field does not help in this case.

  13. sskhalsa
    Member
    Posted 17 years ago #

    i fixed this error by renaming wpmu-settings.php.dist to wpmu-settings.php

    Warning: main(/my_path/mublogs/wpmu-settings.php): failed to open stream: No such file or directory in /my_path/mublogs/wp-config.php on line 86

    Fatal error: main(): Failed opening required '/my_path/mublogs/wpmu-settings.php' (include_path='.:/usr/local/lib/php') in /my_path/mublogs/wp-config.php on line 86

  14. sskhalsa
    Member
    Posted 17 years ago #

    im gettin the .htacess error thingy as well

    10-03-05 release

About this Topic

  • Started 17 years ago by soladon
  • Latest reply from sskhalsa