The MU forums have moved to WordPress.org

Craziness continued - is it WP or WPMU? (23 posts)

  1. maconmacguy
    Member
    Posted 14 years ago #

    Still working with the same problematical blog. After hassling with the database for longer than I care to admin, I decided to just reinstall. (Hmmmm... can't remember if the original was 2.5 or 2.6).

    Uploaded the 2.6.2 files, leaving the config file AND my wp-content folders alone.

    Site came up - had an admin password issue (now resolved - I'm writing these things down in a file this time!).

    All the previous data is in the database (I can see the original entries, blogs, etc). Only 1 blog is showing up - and there is no reference anywhere on the dashboard to multiple blogs (or even an option to add another blog - just users.)

    The bottom of the screen reads
    "Thank you for creating with WordPress | Documentation | Feedback | Version 2.6.2"

    So was I "stooopid" and downloaded the wrong thing (I don't think so) - does this coding not like the database setup - is there something I need to tweak in the database....

    The GOOD news is that the site no longer whines about the domain being wrong.......that is at least an improvement. AND the modified theme I built is showing up, as are the plugins.

    -----
    I hope one day to pass along the help I've been given here!

  2. andrea_r
    Moderator
    Posted 14 years ago #

    If you don't have a Site Admin menu, then you installed single WP instead of wpmu.

    maybe you should tackle this well-rested with a keg of caffeine. :D

  3. dgilmour
    Member
    Posted 14 years ago #

    Did you remember to copy over the .htaccess file too?

  4. andrea_r
    Moderator
    Posted 14 years ago #

    If he didn't copy the htaccess, it would still show a list of sub blogs in the backend. The htaccess just controls permalinks & rewrite rules.

    And if its WordpressMU, the footer says
    "Thank you for creating with WordPress MU | Documentation"

    the right download file:
    http://mu.wordpress.org/download/

    Also note that the MU section of this site still has the OLD layout. Everything relating to SINGLE user WP has the NEW layout.

  5. maconmacguy
    Member
    Posted 14 years ago #

    Ah, the joys of id10T errors! I had BOTH Wp and WPMU in separate folders on my desktop (working two different projects). I copied over the wrong set.

    I'm hoping the rest of my problems can be solved this quickly!

  6. maconmacguy
    Member
    Posted 14 years ago #

    Hmmmmm.... after a rest and some good strong coffee, all files have been uploaded. NOW it's a WPMU install (woohoo) - confirmed by logging in - but none of the existing blogs are showing up (but they still exist in the database).

    Getting the "Easy Tiger 404 error" message.

    Hmmmmmmm........

  7. andrea_r
    Moderator
    Posted 14 years ago #

    Subdomains or subfolders?

  8. maconmacguy
    Member
    Posted 14 years ago #

    Subfolders (as in domain.com/myblog - right?)

    I can access them through the Site Admin link - they are listed. Can't "visit' the site, though. Clicking on the edit and backend links takes me to the "main" blog (#2 in the db).

    Also interesting - I'm told this is WPMU 2.6.2 - I need to upgrade to WPMU 2.6.2.

    I think after I finish updating a couple of plugins I'm going to have it update itself and see if that fixes a variety of things The database has already been updated (/wp-admin/update.php).

  9. maconmacguy
    Member
    Posted 14 years ago #

    Well the auto-update procedure completed, but nothing has changed. All plugins are updated as well.

    So the sitewide admin pages do allow access to the variosu blogs, but none of the links work. The "edit" and "backend" links go to the main blog.

    Nothing looks weird in the DB. What would happen to the DB if I do the complete upgrade (wp-admin/upgrade.php) - or is it wp-admin/update.php?

    Time for a break and coffee.

  10. maconmacguy
    Member
    Posted 14 years ago #

    The answer is..... nothing. The database has been successfully updated, and doing the upgrade just kicks it back out to the dashboard.

    .... and WordpressMU 2.6.2 is still telling me I need to upgrade to WordpressMU 2.6.2.

    I'll probably keep adding in the mysteries and solutions here, because perhaps someone will find it useful.

    More updates when there's something to report.

  11. andrea_r
    Moderator
    Posted 14 years ago #

    Here's what I don't get - WPMU have *never* shown the "you need to upgrade message". So you shouldn't be seeing that unless in the latest build somewhere it got overlooked.

    (and I'm not seeing it in a handful of very recent installs and upgrades)

    The correct upgrade link for MU is /wp-admin/wpmu-upgrade-site.php, under the Site Admin menu. you sure you ran that one?

  12. andrea_r
    Moderator
    Posted 14 years ago #

    Also, got a link?

  13. maconmacguy
    Member
    Posted 14 years ago #

    lakewildwood.org

    I ran the wpmu-upgrade-site.php - it says "All Done" after a suspiciously short amount of time (Then again there's only 15 blogs in my setup).

    Made no difference - thanks for the link, though, I hadn't found that one.

    My gut says this is related to some backside database changes made when I stupidly "upgraded" from WPMU 1.5 to WP 2.6.2 - I uploaded the wrong set of files (what I get for keeping both sets on the desktop and doing 2 things at once). Gotta love the self-inflicted id10t errors..

    I went back and replaced everything with the correct set of files - including wp-content/index.php and blogs.php, ran the "upgrade" link on the dashboard.

    Other than the fact that all of the "other" blogs are coming up "Error 404" on the site, there are 2 other weirdnesses that I think are related:

    1) No matter what blog I select in the dashboard to edit, the dashboard "stats" ("You have 2 posts and 5 pages....")always refer to the front blog.(Blog ID 1)

    2) The Dashboard (right after the msg about what theme is being used) says this:
    This is WordPress version 2.6.2. Update to 2.6.2
    .. But the bottom of the screen says:
    Thank you for creating with WordPress MU 2.6.2

    The table wp_blog_versions has one record:
    blog_id db_version last_updated
    1 8204 2008-10-07 13:56:04

    The table wp_blogs has 15 records - there are additional fields in the table that aren't listed here (registered, last_updated, public, archived, mature, spam, deleted, lang_id)

    blog_id site_id domain path
    1 1 http://www.lakewildwood.org /
    2 1 http://www.lakewildwood.org /webmaster/
    3 1 http://www.lakewildwood.org /calendar/
    4 1 http://www.lakewildwood.org /board/
    5 1 http://www.lakewildwood.org /communications/
    etc. down to blog_id 15.

    So I'm wondering if the fact that wp_blog_versions exists with a field blog-id AND wp_blogs also references a different set of blog_ids is causing the problem.

    Hmmmm... I'm also still getting a "plugin editor has been disabled" error when trying to check plugin settings. I still think this a secondary to the other errors, though.

    Ideas?

  14. andrea_r
    Moderator
    Posted 14 years ago #

    I'm thinking you messed up the db when you accidentally it.

    I mean, accidentally added single WP rather than WPMU. Got a db backup? I'd restore that and do the right upgrade.

  15. VentureMaker
    Member
    Posted 14 years ago #

    I second andrea. Too much pain to debug in this situation :)

  16. maconmacguy
    Member
    Posted 14 years ago #

    I'm not sure I have a valid backup (I know, I know.....). This whole issue started with a domain problem, and it's possible the backups from that point got hosed as well.

    Hmmmmmm....... wonder if I could export just the blog tables (wp_1, wp_2, etc) - then kill off the existing tables and let WPMU re-install itself.

    Then reimport the blog tables. I guess I'd need to use the dashboard to setup the blogs first, then on reimport everything should work.

    Does this sound feasible?

  17. maconmacguy
    Member
    Posted 14 years ago #

    I just have one more hour to work on this, so I'm doing a full backup, then a partial (just the wp_X tables) and redoing the install.

  18. andrea_r
    Moderator
    Posted 14 years ago #

    Yeah, I think so.

    Just make sure you have backups of the backups, go slow and don't panic.

    Mmmm... you may be able to reimport the user table too. Probably everything but the site=specific tables woudl be okay to re-import.

  19. maconmacguy
    Member
    Posted 14 years ago #

    My oldest backup exhibits the same symptoms (booooooo), so I'm wiping the whole thing and starting from scratch. After I get the site up again I'll try importing the individual blogs.

    By "site-specific" do you mean the "wp_whatever" tables (i.e. NOT wp_blognumber)? (Makes sense, just checking).

    Good idea about the user table. Fortunately that hasn't changed in several weeks, so I can export it separately.

  20. andrea_r
    Moderator
    Posted 14 years ago #

    "By "site-specific" do you mean the "wp_whatever" tables "

    I mean the ones with "site" in the table name. :D

  21. maconmacguy
    Member
    Posted 14 years ago #

    well, duh! {SMACK}

    hmmm.... need coffee.

  22. maconmacguy
    Member
    Posted 14 years ago #

    The FINAL update (probably) - for posterior's I mean posterity's sake.

    ; )

    Site is ALMOST all the way back up - have some cleaning up to do, and found out the contact forms aren't working (not related to the other problems - probably a server config issue that I haven't nailed down yet)

    To Sum up the original problem:

    1. Site originally set up on a "temp" domain.
    2. When the dns changed to point to the server, WPMU got thoroughly confused.
    3. I went through the DB and manually changed all the URL references - made no difference.
    4. RE-uploaded the PHP files (except for wp-content fodler). Made some difference.
    5. Decided what the heck - did a DB and files backup, and then uploaded what I THOUGHT was the 2.6.2 update.
    6. Actually uploaded and installed the 2.6.2 WORDPRESS (not WPMU) update. This messed with the database, and was not a good thing.
    7. Uploaded and installed the correct files - but the site still confused. One part of the dashboard IDs the site as WPMU 2.6.2 - another part IDs as Wordpress 2.6.2, and I need to update to WP 2.6.2.

    Of course, I didn't have a good backup of the database - pre-error. That would have been too easy!

    How I fixed it:

    1. Backed up the database.
    2. Backedup PART of the DB to a different file - specifically wp-users table, and then all the files for each individual blog (all at once).
    3. Created a brand new database for the new install, using the massively creative name of WPMU2.
    4. RE-UPLOADED the WPMU files - killed off the wp-config file to do a brand new install. (Kept the wp-content folder intact). Accessed index.php online, and started a fresh install - selecting the brand new WPMU2 database.
    5. Did the initial setup (theme selection, , settings, etc) just to make sure things are working.
    6. Back to phpmyadmin - imported the previously backed-up users table and the individual blogs backups.
    7. Go into each blog and clean up some odds and ends (custom headers had gone wonky - resetting to default fixed them for now, since I had modified the template to use the site logo. Each area will eventually have its own version of the logo, but that's for later).

    After testing I'll bring it back to the front.

    DISCLAIMER: The above was written from memory, which has been shown to be faulty, especially this week. I very well may have left off a critical piece of information, so use with caution. Better yet, don't be an idiot like I was in making these mistakes - be creative and make your own idiotic mistakes!

  23. andrea_r
    Moderator
    Posted 14 years ago #

    "be creative and make your own idiotic mistakes"

    I vote we make this the forum tagline.

About this Topic

  • Started 14 years ago by maconmacguy
  • Latest reply from andrea_r