The MU forums have moved to WordPress.org

MU with xampp on localhost - solution'd! (12 posts)

  1. indextwo
    Member
    Posted 13 years ago #

    Hey everyone,

    I just wanted to post the solutions I've discovered on a couple of issues that seem to be fairly common when installing WPMU locally.

    Just so's you know, I'm running Windows XP SP3 with xampplite 1.6.6 with just Apache and MySQL running.

    I did spend a couple of days scatching my head, trawling the forums, scratching my head s'more and trawling blogs, and this is what I came up with to get everything up, running and working.

    First: READ THE README FILE. Even if you only read as far as line 30. Lines 21 - 25 are particularly helpful, and refer to the file httpd.conf which should be located in C:\xampplite\apache\conf or similar:

    2. In the <Directory> directive of your virtual host, look for this line
    "AllowOverride None"
    and change it to
    "AllowOverride FileInfo Options"

    First off, as you might notice, WPMU doesn't want to run on http://localhost - it wants a domain extension to run with.

    Go to c:\WINDOWS\system32\drivers\etc\ and edit the file hosts with something like Wordpad or Notepad. You should find one of the first lines looks something like this:

    127.0.0.1 localhost

    Simply append 'local.domain' or whatever domain extension you'd like to the end of this line, thus:

    127.0.0.1 localhost local.domain

    After restarting Apache and going back to your WPMU install, using this address:

    http://local.domain/MyWPMUsite/

    ...assuming that's where you unzipped your files. You should then be able to start a successful installation...

    ...and then you might start getting 'Internal Error 500' thrown up for practically anything you try to do.

    I screwed around with trying to CHMOD local files, etc. But in the end, I just needed to edit one line in the httpd.conf file; search for the following line:

    #LoadModule rewrite_module modules/mod_rewrite.so

    ...and simply uncomment it by removing the hash (#) at the start. You will need to stop then restart Apache, but you *should* find everything working just luverly! I found that last trick here

    Hopefully that's helpful to some people suffering with the same localhost installation issues that plagued me for a few hours.

  2. demonicume
    Member
    Posted 13 years ago #

    but can you access it from other wan-side machines?

  3. indextwo
    Member
    Posted 13 years ago #

    I haven't tried at all - this was only a local installation on a single machine. I'd guess that entirely depends on your WAN setup. I only figured this out a couple of hours ago!

  4. sean01234
    Member
    Posted 13 years ago #

    Some observations while getting MU running locally on XP SP2 with Apache server (2.2.9 win32), MySql (5.0), and PHP (5.2.6).
    1) When modifying the hosts file (C:\WINDOWS\system32\drivers\etc\hosts), after several attempts, this (suggested above) did not work for me:
    127.0.0.1 localhost local.domain
    But this did:
    127.0.0.1 localhost.localdomain localhost
    So when filling out the Wordpress setup fields, I entered "localhost.localdomain" into the Server Address field.
    Since my wordpress files are in htdocs/wordpress, this is my local wordpress url: http://localhost.localdomain/wordpress/
    2) The wordpress README.txt instructions said to look for a <Directory> directive and change:
    "AllowOverride None" to "AllowOverride FileInfo Options"
    There were three <Directory directives in my httpd.conf file, only the first one needed the change.
    3) The wordpress README.txt instructions also say to update the <VirtualHost> section
    I didn't find such a section in my httpd.conf file so I didn't do this step.
    4) and while in httpd.conf, a friend recommended updating <IfModule dir_module> to include index.php
    <IfModule dir_module>
    DirectoryIndex index.php index.html index.htm
    </IfModule>
    Hope that helps.

  5. alamster
    Member
    Posted 13 years ago #

  6. stompy1208
    Member
    Posted 13 years ago #

    Thanks a bunch... worked like a charm! :)

  7. damerchan
    Member
    Posted 13 years ago #

    Muchas gracias, thanks, thanks, thank you :D

  8. tomleads
    Member
    Posted 13 years ago #

    Fantastic. Works a treat

  9. tomleads
    Member
    Posted 13 years ago #

    I spoke too soon.

    When I add new blogs, it says it can't find them: such as http://tm.local.domain/mu/

    "Server not found" - any ideas?

  10. tomleads
    Member
    Posted 13 years ago #

    Ok, sorted (for now anyway :P ) edited the host file to include:

    127.0.0.1 localhost local.domain
    127.0.0.1 test1.local.domain
    127.0.0.1 test2.local.domain

  11. Satoph
    Member
    Posted 13 years ago #

  12. Maine Web Guy
    Member
    Posted 13 years ago #

    I have recently gotten multiple Wordpress MU installations using subdomains setup on my local Windows machine with XAMPP, and I wrote quite a lengthy post of the process that I learned along the way... Hope it helps anyone who cares.

    http://mainewebguy.com/2009/getting-wordpress-mu-to-work-with-subdomains-on-local-windows-machine/

    Thanks!

About this Topic

  • Started 13 years ago by indextwo
  • Latest reply from Maine Web Guy