The MU forums have moved to WordPress.org

Redirect loop when logging on after a blog is created (50 posts)

  1. MAVIC
    Member
    Posted 15 years ago #

    Same issue here. 2.7 new install on a server that supports WP just fine. I logged in, created a new user. Logged out, logged in with new user and got the loop. I tried another browser and another computer. Same issue.

    I tried the original user and it worked fine, but the new user cannot login without too many redirects.

  2. Hickeroar
    Member
    Posted 15 years ago #

    New install of 2.7 here. Had the problem. Clearing all my cookies also worked for me.

  3. davethom
    Member
    Posted 15 years ago #

    this is what worked for me

    Wordpress-mu gives the server redirect loop on plesk vhosts wheninstalled in a sub-directory _unless_ you “chmod -R apache” on the install sub-directory. Another evening spent in front of a computer!

  4. ccano
    Member
    Posted 15 years ago #

    Clearing my browser's cookies worked for me as well.

  5. webchilly
    Member
    Posted 15 years ago #

    Hii Can any body help me installing Wordpress MU? Call me on +1-505-404-6627 / SKYPE: anirajkumar.

    A.Niraj Kumar
    http://www.anirajkumar.com

  6. SteveAtty
    Member
    Posted 15 years ago #

    Why not post your problems here?

    I assume you have done a good search across the forums to see if you problems have been answered elsewhere.

    If not then asking here means you get the input from a lot of people who really can help and it also helps those who may have the same problems in the future

  7. andrea_r
    Moderator
    Posted 15 years ago #

  8. ColaTM
    Member
    Posted 15 years ago #

    Junk

  9. jugularbean
    Member
    Posted 15 years ago #

    I've tried everything posted here. But am still unable to solve the problem. I'm on mediatemple dv hosting.

  10. THLopes
    Member
    Posted 15 years ago #

    Cleaning the cache and cookies of the browser solved for me.

    Notice that I already had put the DEFINE code tip mentioned on the begining

  11. K3rM1t
    Member
    Posted 14 years ago #

    We had the same issue on our site.
    All new blogs created by non-site admin users would loop when accessing wp-admin. None of the above solutions helped. After digging through the db, code and some debugging info we found that in the wp_<site_id>_options table the wp_<site_id>_user_roles option was getting set incorrectly. The Administrator role was missing all capabilities. The root cause was a plugin which was setting hooks too early. After ensuring the plugin was hooking in at the appropriate place, this problem was resolved.

    If you find a bad plugin, make sure it isn't inserting itself too soon.

  12. jeff5311
    Member
    Posted 14 years ago #

    hmmmm... i had this issue and realized the link in the theme i was using had a missing trailing slash "/" to the Dashboard. The link in your theme should be:

    http://www.example.com/wp-admin/ (notice the "/" at the end)

    i'm sure this is an .htaccess error that i could fix, but changing the link to the admin console in the theme fixed the issue.

    try accessing your dashboard via "http://www.example.com/wp-admin" (without the trailing slash) and "http://www.example.com/wp-admin/" (with the trailing slash) to re-create it.

  13. Shurley
    Member
    Posted 14 years ago #

    Try adding this into wp-config.php

    define('ADMIN_COOKIE_PATH', '/');
    define('COOKIE_DOMAIN', '');
    define('COOKIEPATH', '');
    define('SITECOOKIEPATH', '');

    Thanks VentureMaker! That helped me out.

  14. TracyReaderDad
    Member
    Posted 14 years ago #

    OK, yesterday I started to move one of my blogs to Yahoo using WP. I have more than one issue, but, the REDIRECT LOOP seems to be appropriate for this discussion.

    I am not a power programmer, so my questions may seem elementary..and I may need a bit more coaching.

    1. Where do I find wp-config.php? I will try to put in the code mentioned above in it, but, I do not know where to look.

    2. Can I put it anywhere, or will the placement be apparent when I see the code?

    You can see the issue at http://TracyReaderDad.com Then click on one of the "Authors" in the left column...that is when the "REDIRECT LOOP" issue pops up.

    Thanks ahead of time...

  15. tim.moore
    Member
    Posted 14 years ago #

    wp-config.php is located in the top most directory of your wordpress installation. (Likely /public_html/ if you are using a web host).

    You can put the define() commands anywhere in that file, so long as they are complete.

  16. TracyReaderDad
    Member
    Posted 14 years ago #

    Ah...thanks, now I know where that is. :-)

    UPDATE: I did an "automatic re-install" and now it appears to be working! I'll keep banging on it to see when / if it fails again.

    Should I put the defines in even though it is working now? Will they hurt? Are they needed?

    Thanks again!

    Mike

  17. tim.moore
    Member
    Posted 14 years ago #

    They aren't needed, but it won't hurt anything to have them there.

  18. TracyReaderDad
    Member
    Posted 14 years ago #

    Almost immediately after re-installing 2.8.4 automatically, the REDIRET came back. It worked great, then when I went back in...gone.

    I then put in the code:

    define('ADMIN_COOKIE_PATH', '/');
    define('COOKIE_DOMAIN', '');
    define('COOKIEPATH', '');
    define('SITECOOKIEPATH', '');

    Still not working!

    Not sure what to try next...

    Thankfully, my Wordpress.com blogs are still active and working great.

  19. TracyReaderDad
    Member
    Posted 14 years ago #

    One more item: I disabled all my plug-ins and have cleared my cache and cookies many times.

  20. TracyReaderDad
    Member
    Posted 14 years ago #

    I lied..one more thing before the weekend:

    The link to an "Author" is given as:

    http://tracyreaderdad.com/blog/category/barry-eisler/

    There is a "blog" folder, but, within that there is no "category" folder.

    Could that be the cause?

About this Topic

  • Started 15 years ago by lnuxguy
  • Latest reply from TracyReaderDad