The MU forums have moved to WordPress.org

.htaccess, blogs.dir & uploads Permission show "99 99" (11 posts)

  1. Success
    Member
    Posted 11 years ago #

    After installing, I saw the permissions for

    .htaccess
    blogs.dir
    uploads

    show as "99 99" Owners/Group.

    Is this correct?

  2. VentureMaker
    Member
    Posted 11 years ago #

    Permissions 9999? Never saw such a thing, very strange... Who's the owner of files?

  3. Success
    Member
    Posted 11 years ago #

    Filezilla show the permission as "99 99"

  4. tdjcbe
    Member
    Posted 11 years ago #

    I have. See it all the time when the ownership for files and directories is not set correctly. Ususally we're moving a site between servers or reinstalling from a backup. Do a chown for all of the files and set them to the correct user account to fix.

  5. andrea_r
    Moderator
    Posted 11 years ago #

    Can you change them? 755 would be a good start.

  6. tdjcbe
    Member
    Posted 11 years ago #

    I think we may all be getting confused a bit here. Is the permissions set to '99 99' or the Owner/Group ownership set to that?

  7. andrea_r
    Moderator
    Posted 11 years ago #

    Does Filezilla show Owner/Group?

  8. Success
    Member
    Posted 11 years ago #

    tdjcbe, you are right. I overlooked it.

    "99 99" is Owner/Group

    The permission is 755.

    But when I try to change the permission, I get error like this

    Command: SITE CHMOD 755 blogs.dir
    Response: 550 Could not change perms on blogs.dir: Operation not permitted

    I am also unable to delete or edit any files with "99 99" or files inside blogs.dir, I get error like this

    Response: 550 Could not delete example.jpg: Permission denied

    What should the correct Owner/Group setting for those directories? How to change that?

    Thanks a lot guys.

  9. Success
    Member
    Posted 11 years ago #

    Update: problem solved.

    For others facing this problem, this was what solved it.

    When I SSH using the account username and chown, I get the errors
    "Operation Not Permitted"

    I was able to chown only after I SSH as root admin and I run this.

    chown -R USERNAME:USERNAME /home/USERNAME/public_html/wp-content/blogs.dir

    For the USERNAME:USERNAME part, mine was both the account name, yours may be different.

  10. Success
    Member
    Posted 11 years ago #

    After setting owner/group to username, I get this error when trying to upload images.

    On main wpmu site
    "Unable to create directory /home/USERNAME/public_html/wp-content/blogs.dir/1/files//2008/10. Is its parent directory writable by the server?"

    On domain mapped sites
    "The uploaded file could not be moved to the upload folder."

    Only when I set the Owner/Group back to nobody did the upload works again.

    Please advise. What should be the correct Owner/Group?

    I also came across this useful post at

    http://mu.wordpress.org/forums/topic.php?id=9077

    camner
    Member

    There are a lot of posts about this issue both on this forum and elsewhere. I ran into this issue recently as well. I have shared hosting, and after a lot of digging, this is what I found out (YMMV...):

    0. The fundamental issue here seems to be about who "owns" the folder 'blogs.dir' and its subfolders. If one runs ones own server and has complete access to everything on it, ownership is straightforward to determine and change, if needed. If one is on shared hosting, folder ownership is largely invisible, and one can't typically change it oneself.

    1. When Wordpress MU is first installed, all of the files and folders have owner and group set to whatever username the server is set to assign for you (if you are on shared hosting, that decision is made by the host, not you!)

    2. Until the first time one tries to upload an image, the wp-content folder does NOT contain a folder called 'blogs.dir'.

    3. The first time an image is uploaded, a folder called 'blogs.dir' is created. The owner and group for this folder and all of its subfolders is set to 'nobody'. I have no idea why it is important for 'blogs.dir' to have different ownership, but it seems to matter a great deal.

    4. The implications of having a folder set to 'nobody' is that one cannot delete it or upload files directly to it using FTP, but one CAN upload files using the WPMU file/image uploader.

    5. If, for any reason, blogs.dir or any of its subfolders has its ownership changed away from 'nobody', the uploading of images will fail with the famous error message "...is its parent directory writeable by the server?"

    6. Some people have tried to solve this by changing file/folder permissions. Some have succeeded by changing the permissions to 777. Others have not had this work. The issue does not seem to be fundamentally a permissions issue but an ownership issue.

    7. With shared hosting, I couldn't even SEE the ownership of the files and folders until I asked my host to enable SSH access. Via SSH access I could see the ownership by typing ' ls -l ' I still couldn't change the ownership to 'nobody' and had to have my webhost do it for me.

    8. Once 'blog.dir' and all subfolders and files had both its owner and group set to 'nobody', everything worked normally.

    I hope this post is helpful to some people. Obviously a lot of us have torn our hair out over it!

  11. Success
    Member
    Posted 11 years ago #

    chown -R username:apache_user /home/username/public_html/wp-content

    chmod -R 775 /home/username/public_html/

    For me, apache_user is "nobody".

    Thanks to Ovidiu
    http://mu.wordpress.org/forums/topic.php?id=2794

    "this way apache has ful rights so you coudl actually use a theme editor, or a plugin editor or whatever (aka upload files) and apache is able to write.."

About this Topic