The MU forums have moved to WordPress.org

404 redirect is broken (11 posts)

  1. Konstan
    Member
    Posted 15 years ago #

    After I upgraded to Mu 2.6.2 and I noticed that the 404 redirects are broken now. When you enter a blog url that doesnt exist, it doesnt redirect to the wp-signup.php page.

    I did change my old htaccess with the new one from the zip file, so it now looks like this:

    RewriteEngine On
    RewriteBase /

    #uploaded files
    RewriteRule ^(.*/)?files/$ index.php [L]
    RewriteCond %{REQUEST_URI} !.*wp-content/plugins.*
    RewriteRule ^(.*/)?files/(.*) wp-content/blogs.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteCond %{REQUEST_URI} ^.*/wp-admin$
    RewriteRule ^(.+)$ $1/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>

    What could be wrong? I've checked my logs and there is nothing. It used to redirect to wp-signup if the url didnt exist, but now you get a 404 ugly page...I'd like it to go back to the redirect to wp-signup.

    You can see for yourself: http://bloghost.cl/asdasda

  2. tdjcbe
    Member
    Posted 15 years ago #

    Please check your wp-config.php file:

    http://trac.mu.wordpress.org/changeset/1377

  3. Konstan
    Member
    Posted 15 years ago #

    Ah nice, that fixed it, almost. I'd like it to redirect as it used to, to the signup with the username the person was searching.

    Right now I have define( 'NOBLOGREDIRECT', '/wp-signup.php' );

    And I dont know what to add after the php so it uses the entered word. It should be wp-signup.php?new=$name, but I dont know what to add to $name :D

    Also, the code in 2.6.2 in wpmu-settings.php is different from the one you linked to, but it still works. I guess it was revised later on. This'll teach me to check the trac more often since I never knew of this change when I upgraded.

  4. andrea_r
    Moderator
    Posted 15 years ago #

    The trac has an RSS feed. It's pretty handy. :)

  5. Konstan
    Member
    Posted 15 years ago #

    Ah damn, just noticed that since I got the redirects working again, the MuTags broke :( When you click on a tag it redirects you to the signup page.

    Will have to take a look once I get time to see how to fix this :(

  6. rfrovarp
    Member
    Posted 15 years ago #

    Care to share how you fixed it?

  7. Konstan
    Member
    Posted 15 years ago #

    In your wp-config.php add:

    define( 'NOBLOGREDIRECT', '/wp-signup.php' );

    change wp-signup.php to wherever you want it to go.

  8. rfrovarp
    Member
    Posted 15 years ago #

    Thanks. For some reason I'm not getting 404's, which is preventing that from working. That seems to be my current problem.

  9. VentureMaker
    Member
    Posted 15 years ago #

    When I open http://bloghost.cl/asdasda I'm redirected to signup page

  10. Konstan
    Member
    Posted 15 years ago #

    Because I fixed it already :P

    It just broke the tags now :(

  11. Konstan
    Member
    Posted 15 years ago #

    Does anyone have MuTags working with this new version? Since /tags/ doesnt exist, I cant load the tags.

About this Topic